PHP: Hypertext Preprocessor, also referred to as PHP, is a popular web programming language, which is used to create dynamic sites with interactive components like forums, e-learning sites or community sites. In contrast to static HTML-based websites, a PHP-driven site can show different web content to each visitor under the same exact URL. Because PHP-based web-based applications can be managed through a Control Panel tool, which you can log on to from any browser, you will not have to possess any programming experience or practical experience in order to run a PHP-driven site. The fact that 100s of millions of websites all over the world are created with PHP is an indication of the popularity and the simplicity of use of the language. You only have to confirm if the server on which your website is hosted supports the same exact PHP version as the one that you used while developing the website.

PHP 4 and PHP 5 Support in Hosting

Our hosting servers support several versions of PHP, which implies that your sites will run faultlessly even if your scripts are outdated. We accept the fact that an old site does not invariably imply a vulnerable one as you may have carried out lots of code mods. That’s the reason why we support PHP 5.5, 5.4, 5.3, 5.2 and 4 and you can decide which version will be enabled for your hosting account. You can change the version with just one single mouse click through your Hepsia hosting Control Panel and the update will be applied immediately. If you want to run both older and newer scripts, there is even a possibility to use a different version of PHP for each domain name of yours at the same time.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Our Linux semi-dedicated hosting packages support multiple versions of PHP, which means that you will be able to use all the web applications that you have built through the years. The Hepsia hosting Control Panel, which comes with every semi-dedicated account, will allow you to enable the needed version with one single click of the mouse. You can select between PHP 5.5, 5.4, 5.3, 5.2 and 4. In case you want to host multiple websites in the exact same account and they have special requirements in relation to the hosting platform, you will be able to choose a different PHP version for each one of them no matter which version is enabled for the account as a whole. This is possible owing to our custom-created cloud hosting platform, which permits us to run different PHP versions simultaneously. By contrast, most web hosting vendors typically support one, in rare cases – two versions.